Our first Tizen application

Gabor Paller's picture

The Tizen platform was formed by merging bada from Samsung and MeeGo, a leftover from the Intel-Nokia common effort for creating an open-source operating system. Even though the 2.0 version of the development environment has just been released, the application environment is still very much in the definition phase. Tizen 2.0 as it is only exposes web application model to application developer. This means that the only way to create applications is the familiar HTML5-CSS3-JavaScript technology base. There is no official way to access the underlying Linux layer and its support libraries.

 

This makes the application platform somewhat limited but it also provides access to the large web developer community. Also, there has been a lot of speculation whether Tizen would support any other application model. For the moment there is no such option.

 

Let's see a simple project to demonstrate a Tizen application! The example project is attached to this post, you have to be logged in to the Sfonge site to access it. The application is the first iteration of the Interesting Words series of apps. We have already seen the bada version for bada's web application model.

 

This time I built the application without any particular framework, just using plain vanilla HTML+JavaScript. Just ask if you don't understand something, I feel the app itself is quite simple. Get the Tizen SDK from here and install it. As a sidenote, I have to admit that I could not get the SDK work on my 64-bit Ubuntu system. The Eclipse IDE on which Tizen SDK was built always complained about the missing web renderer and when I tried to specify it, the JVM crashed terribly. The Windows installation went smoothly, however, so I recommend using Windows for the first experiments.

 

The example project can be imported as usual in Eclipse. Tizen SDK offers two options to run it. The quick way is to run the application in Chrome. The Tizen SDK calls it "Web simulator" and it can be activated by right-clicking the project and choosing Run as/Tizen Web Simulator application. Advantage of the Chrome simulator is the fast execution and it is quite similar to the appearance on the device. Here is how our simple application looks like:



The other execution option is the Tizen emulator. The location is a bit tricky: first open the Connection Explorer with Window/Show view/Connection Explorer then click on the Emulator Manager icon. After you created and launched the emulator, the application can be executed on it by Run as/Tizen web application command.


It must be admitted that Tizen emulator is terribly slow. Hopefully it will get faster in later revisions. Here is how our application looks like in the emulator.

 

Attached file: 
Taxonomy upgrade extras: 
Bartholomew Simpson's picture

This might be helpful in getting the IDE running on 64-bit Linux:
https://www.nixuopen.org/blog/2012/10/tizen-20-64-bit-debian-wheezy/

Gabor Paller's picture

Very handy post. I managed to install the SDK on my (originally unsupported) OpenSuSE 12.2 installation.
However, I ran into the same problem as on Ubuntu: when I try to create a new web project, Eclipse talks back like this:
Unhandled event loop exception
No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]

I googled and found a number of advices but none worked. So I eventually gave up and fell back to Windows. Which is problematic enough as Tizen IDE hangs regularly.
 

Sameer Patil's picture

Hi Gabor,

I am trying to install Tizen 2 sdk and emulator on opensuse. How did you managed to install the same on opensuse ? I tried to install Ubuntu 32 bit tizen sdk installer on opensuse but getting error. I couldn't able to find any info on google to install it on opensuse.

It would be great if you share the same with me.

Thanks!
Sameer

Gabor Paller's picture

Sameer, please follow Bartholomew's blog post:
https://www.nixuopen.org/blog/2012/10/tizen-20-64-bit-debian-wheezy/
On-line installer did not work for me so I went for the off-line installer.
Note, that after I successfully installed the IDE and started it, I received that ugly MOZILLA_FIVE_HOME not set error message when I tried to create a Tizen project. I was not able to get past this error.

Sameer Patil's picture

Thanks Gabor, I could able to launch emulator manager on my opensuse but I am getting glibc 2.5 require error when I try to launch emulator image. Are you using opensuse 12.2 ?

I have built Tizen platform using obslight gui on opensuse but I also require emulator to run on opensuse so I can debug the tizen platform. My opensuse version in 12.1. I guess I need to upgrade it as 12.2 have glib 2.5.

Bartholomew Simpson's picture

Set the environment variable MOZILLA_FIVE_HOME to the native browser's installation folder. e.g. setenv MOZILLA_FIVE_HOME /usr/lib/mozilla
Set the environmnent variable LD_LIBRARY_PATH to include MOZILLA_FIVE_HOME. e.g. setenv LD_LIBRARY_PATH ${MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}